September 23, 2014, 04:28:18 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: Howto use MiniLab with Live 9 in Absolute Mode  (Read 559 times)

danzweid

  • Newbie
  • *
  • Posts: 1
  • Karma: 1
Howto use MiniLab with Live 9 in Absolute Mode
« on: August 11, 2013, 12:44:28 am »

Hi everyone,

after one day of frustration because of wild-going encoder behaviour I now figured out a way that works well for me in Live 9:

This work-around will make "Absolute Mode" become usable in Live: 1 rotation hardware = 1 rotation in software)
Still no real endless rotary-encoder-functionality, but at least better responding!

1st make sure that you are using the latest firmware (2.1.0.1 when writing this).
Install the Ableton script found here:
http://www.arturia.com/evolution/en/products/MiniLab/resources.html
(when installing on a Mac "Library" might be hidden - go to your User-directory in Finder and choose "Go to" from Top-Menu, then type in "Library")

Now the important part: Change the included "UserConfiguration.txt" by setting "EncoderMapMode: Absolute" instead of "LinearBinaryOffset"
(or use the attached file of this post)

Set the MiniLab to MIDI Preset 1 (Absolute Mode) and start Live.
In Live's MIDI-Prefs I set up MiniLab as "track" only, no remote.
If you want you can make Ableton catch your midi-encoders - If you don't, parameters will jump after changing presets in Analog Lab!

Hope this will keep someone from going mad over the bad encoder-behaviour like I did - because I really like the AnalogLab Software!

Anyway, Arturia, please fix encouder-behaviour with the next update, as this is still more like a work-around. I would really appreciate if relative-mode worked well in Live.

Dan

 

Carbonate design by Bloc
SMF 2.0.2 | SMF © 2011, Simple Machines