September 02, 2014, 01:40:10 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: Anyone getting virtual MIDI to work?  (Read 1716 times)

andyxr

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Anyone getting virtual MIDI to work?
« on: April 23, 2013, 12:10:13 pm »
I've been trying to get Beatmaker 2 to control iMini via Virtual MIDI. iMini MIDI connection panel says it can see Beatmaker. But the MIDI instrument keyboard in Beatmaker doesn't play the iMini. Other synths (Magellan, Sunrizer, etc) all work just fine.
Anyone else seeing this? It's driving me crazy!

Andy

Orc

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Anyone getting virtual MIDI to work?
« Reply #1 on: April 23, 2013, 01:47:30 pm »
Same problem here. Both iMini and Beat Maker 2 seems to recognize each other in the Midi setup panel but no sound will come out when I play an empty Sampler Keyboard set up to play an external instrument in Beat Maker 2. Another synth (Alchemy) works with Beat Maker 2. And Alchemy can also work with iMini. So it seems like this is a particular problem with Beat Maker 2 and iMini's virtual Midi port connection. Anyone successful in this combination ?

andyxr

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Anyone getting virtual MIDI to work?
« Reply #2 on: April 23, 2013, 02:24:29 pm »
I'll shoot a question onto the Beatmaker forum.. I really want this to work!

EDIT - BM2 forum posted to.
« Last Edit: April 23, 2013, 02:36:52 pm by andyxr »

Orc

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Anyone getting virtual MIDI to work?
« Reply #3 on: April 23, 2013, 04:16:30 pm »
Here is a work around which is not perfect but at least you can play iMini from BM2.
Run an app called "freEWI" in the background and they will connect. I do not know why this work and not the virtual midi inside BM2 and iMini. This workaround has a problem though. The sound will starts to break out if you start to play a lot of notes. It seems like freEWI is not handling the midi info fast enough, or something like that. The funny thing is, if I record the midi performance as audio in BM2's audio track, the audio file comes out fine. No break out.
Hope they will notice the problem and fix it soon..

gmtfd

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Anyone getting virtual MIDI to work?
« Reply #4 on: April 30, 2013, 01:27:50 pm »
Okay, so I've been trying hard to get this to work, because BM2 is my iDAW of choice and I love the sound of iMini. It's by far the best-sounding iOS synth, in my opinion.

I'm using an iPad 4 and iOS 6.1.3.

With BM2 and iMini open and freEWI running in the background (as suggested above) I found I could use BM2 to sequence iMini, but whenever I touched a knob in iMini the knob started flying around seemingly at random.

I then installed MidiBridge. Connecting BM2 and iMini in MidiBridge cured the knobs-flying-around problem. However, it was still necessary to have freEWI running in the background, for some reason.

I then found I could use Audiobus to record audio from iMini into BM2. However, the timing of the recorded notes was not good - none of them were exactly on the beat, and some of them exhibited more latency than others.

I tried the above again this morning, and for some reason now I cannot route audio from iMini into BM2. As soon as I connect the two apps in Audiobus, iMini goes silent.

This is my first attempt at interconnecting apps 'live' (rather than using ACP) and I am reminded of the bad old days of trying to get different bits of hardware to work together!

Please, has anyone got any further with this?

Cheers

Gareth

Mando

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Anyone getting virtual MIDI to work?
« Reply #5 on: May 01, 2013, 03:04:38 am »
First of all, congrats! Really nice sound!

Same here regarding midi, definitely needs an update. Tried BM2 and Genome. There must be an audio buffer related issue. As soon as I try to record through audiobus all gets out of sync.
And midi doesn't work correctly at all without the freEWI app workaround.

Best, Tom

So no musical recording with imini, yet....  :'(

motor

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Anyone getting virtual MIDI to work?
« Reply #6 on: May 01, 2013, 09:34:33 am »
The above posts summarise my experiences too. FreEWI does/did work (for a couple of hours) but now nothing works properly.
It seems that this work around damages iMini in relation to AB and BM2. Is this a conflict with tabletop routing?
Magelan, Sunriser and Animoog work without (many) issues. It's a damn shame as iMini is a very tasty synth and perfect for me.

Please fix Arturia. I promise to sing your praises to anyone who will listen if you do. ;D

gmtfd

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Anyone getting virtual MIDI to work?
« Reply #7 on: January 01, 2014, 11:20:00 pm »
Update: the timing issues I refer to above seem to affect all my synth apps, not just iMini. Therefore I think this may actually be a BM2 issue, or a general virtual MIDI one, rather than an iMini-specific problem. See:

http://intua.net/forums/discussion/3940/virtual-midi-timing-issues#Item_1

Cheers

Gareth

 

Carbonate design by Bloc
SMF 2.0.2 | SMF © 2011, Simple Machines