August 28, 2014, 05:11:06 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: 2600V plugin causing Logic X to crash  (Read 744 times)

Ruari

  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
2600V plugin causing Logic X to crash
« on: October 24, 2013, 06:07:20 pm »
I've hit a small issue where it seems that the Arp 2600 V plugin will cause Logic X to crash. It started when I tried to swap out the Oberheim SEM V plugin for a 2600 V on a channel strip - instant crash.

Quote
Process:         Logic Pro X [421]
Path:            /Applications/Logic Pro X.app/Contents/MacOS/Logic Pro X
Identifier:      com.apple.logic10
Version:         10.0.3 (2911.58)
Build Info:      MALogic-2911058000000000~1
App Item ID:     634148309
App External ID: 16567946
Code Type:       X86-64 (Native)
Parent Process:  launchd [153]
User ID:         501

Date/Time:       2013-10-24 16:01:40.094 +0100
OS Version:      Mac OS X 10.8.5 (12F45)
Report Version:  10

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000130d4edf0

VM Regions Near 0x130d4edf0:
    __LINKEDIT             00000001309b4000-0000000130b7a000 [ 1816K] r--/rwx SM=COW  /Library/Audio/Plug-Ins/VST/Arp2600 V2.vst/Contents/MacOS/ARP2600 V2
-->
    MALLOC_LARGE (reused)  00000001319d7000-0000000131c1a000 [ 2316K] rw-/rwx SM=PRV 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib                  0x00007fff96f89f5e objc_release + 14
1   libobjc.A.dylib                  0x00007fff96f89230 (anonymous namespace)::AutoreleasePoolPage::pop(void*) + 464
2   com.apple.CoreFoundation         0x00007fff9289dd72 _CFAutoreleasePoolPop + 34
3   com.apple.Foundation             0x00007fff8d59e47a -[NSAutoreleasePool drain] + 154
4   com.apple.AppKit                 0x00007fff90bdf27e -[NSApplication run] + 736
5   com.apple.AppKit                 0x00007fff90b83bd6 NSApplicationMain + 869
6   com.apple.logic10                0x00000001060bad49 0x105c36000 + 4738377
7   com.apple.logic10                0x0000000105c387d4 0x105c36000 + 10196

After I had managed to load the 2600 V into the project, I tested a few patches then decided to try another plugin. This time, I selected "No Plugin" from the Logic menu - instant crash.

Quote
Process:         Logic Pro X [587]
Path:            /Applications/Logic Pro X.app/Contents/MacOS/Logic Pro X
Identifier:      com.apple.logic10
Version:         10.0.3 (2911.58)
Build Info:      MALogic-2911058000000000~1
App Item ID:     634148309
App External ID: 16567946
Code Type:       X86-64 (Native)
Parent Process:  launchd [153]
User ID:         501

Date/Time:       2013-10-24 16:31:08.296 +0100
OS Version:      Mac OS X 10.8.5 (12F45)
Report Version:  10

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

VM Regions Near 0:
-->
    __TEXT                 0000000100a28000-000000010189d000 [ 14.5M] r-x/rwx SM=COW  /Applications/Logic Pro X.app/Contents/MacOS/Logic Pro X

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   ???                              000000000000000000 0 + 0
1   libobjc.A.dylib                  0x00007fff96f89230 (anonymous namespace)::AutoreleasePoolPage::pop(void*) + 464
2   com.apple.CoreFoundation         0x00007fff9289dd72 _CFAutoreleasePoolPop + 34
3   com.apple.Foundation             0x00007fff8d59e47a -[NSAutoreleasePool drain] + 154
4   com.apple.AppKit                 0x00007fff90bdf27e -[NSApplication run] + 736
5   com.apple.AppKit                 0x00007fff90b83bd6 NSApplicationMain + 869
6   com.apple.logic10                0x0000000100eacd49 0x100a28000 + 4738377
7   com.apple.logic10                0x0000000100a2a7d4 0x100a28000 + 10196

I'm using OS X 10.8.5, Logic X.0.3, Arp 2600 V 2.5.3

joe.byer@gmail.com

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: 2600V plugin causing Logic X to crash
« Reply #1 on: January 03, 2014, 06:33:43 pm »
Did Arturia ever give any response to this?

I'm having issues with projects that I originally made in Logic Pro 8, moved to Logic Pro X on a new MacBook Pro and saved them as Logic Pro X files. Now when I try to open those Pro X files, something keeps crashing Logic.

I have just invested in the entire V-Collection (had Mod Moog, Mini Moog, Arp and CS-80 on my old system) but if I go thru all these tracks narrow it down to Arturia plugins causing these problems, I may be asking for my money back.

McBizzle

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: 2600V plugin causing Logic X to crash
« Reply #2 on: February 16, 2014, 09:00:26 pm »
I'm having the same issue over here.

 

Carbonate design by Bloc
SMF 2.0.2 | SMF © 2011, Simple Machines