September 03, 2014, 02:01:10 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: warning:MIDI ports  (Read 3292 times)

abertronix

  • Newbie
  • *
  • Posts: 2
  • Karma: 1
warning:MIDI ports
« on: May 28, 2011, 04:27:44 am »
Hi ,
Received Spark a couple of days ago. Absolutely love it and its a pleasure to use. Love the instruments and the variety of Kits that have come with it. I really look forward to importing my kits within Spark as the way the library is set up makes it very easy to change sounds, etc.

 Just one question, when I load it up in Logic I get a warning saying;
 You need to turn off some MIDI connections in your sequencer software. Please go to your sequencers MIDI settings and turn off 'Spark private In' and 'Spark private Out'.

I dont know if Im missing something obvious but I cant find where to change these settings within Logic. It  dont know what effect it has turning off these settings but it still seems to work fine within Logic as far as I can see.

Thankyou!
A

minehead

  • Apprentice
  • *
  • Posts: 22
  • Karma: -8
Re: warning:MIDI ports
« Reply #1 on: May 28, 2011, 05:46:46 am »
Hi ,
Received Spark a couple of days ago. Absolutely love it and its a pleasure to use. Love the instruments and the variety of Kits that have come with it. I really look forward to importing my kits within Spark as the way the library is set up makes it very easy to change sounds, etc.

 Just one question, when I load it up in Logic I get a warning saying;
 You need to turn off some MIDI connections in your sequencer software. Please go to your sequencers MIDI settings and turn off 'Spark private In' and 'Spark private Out'.

I dont know if Im missing something obvious but I cant find where to change these settings within Logic. It  dont know what effect it has turning off these settings but it still seems to work fine within Logic as far as I can see.

Thankyou!
A

it gives you this message in every DAW, I've found that if you just close it it works fine, and by going into "Controller Set-Ups" in MIDI Preferences that if you remove them it still gives you the message and it doesn't change anything...it does work well in Logic, the 16 outputs just load straight up which is fantastic.

Koshdukai

  • Beta-testers
  • Sr. Member
  • *
  • Posts: 436
  • Karma: 19
Re: warning:MIDI ports
« Reply #2 on: May 29, 2011, 04:12:04 pm »
Please go to your sequencers MIDI settings and turn off 'Spark private In' and 'Spark private Out'.
Spark software needs exclusive access to those in/out MIDI ports, so in order to do that, those 2 need to be free of use by the DAW (or any other app).

There's some references to this in the manual, page 75, 7.1.1. Device ports

For instance, on Ableton Live, I had to go to Options, Preferences, MIDI Sync, find those 2 ports and turn them OFF so Live doesn't try to use them, leaving them free for the Spark plug-in.

minehead

  • Apprentice
  • *
  • Posts: 22
  • Karma: -8
Re: warning:MIDI ports
« Reply #3 on: May 31, 2011, 09:33:33 pm »
Hi ,
Received Spark a couple of days ago. Absolutely love it and its a pleasure to use. Love the instruments and the variety of Kits that have come with it. I really look forward to importing my kits within Spark as the way the library is set up makes it very easy to change sounds, etc.

 Just one question, when I load it up in Logic I get a warning saying;
 You need to turn off some MIDI connections in your sequencer software. Please go to your sequencers MIDI settings and turn off 'Spark private In' and 'Spark private Out'.

I dont know if Im missing something obvious but I cant find where to change these settings within Logic. It  dont know what effect it has turning off these settings but it still seems to work fine within Logic as far as I can see.

Thankyou!
A

you need to go into Preferences>MIDI>Control Surfaces>Controller Set-Up, you need to add it if it's not there and then you can choose to turn them off/on...

moogy blues

  • Jr. Member
  • **
  • Posts: 53
  • Karma: 1
    • Acoustic Focus
Re: warning:MIDI ports
« Reply #4 on: May 31, 2011, 09:53:36 pm »
 :(

was hoping not to get stuck on the first hurdle!...in this case midi control.

Keep getting Spark Controller Connection failed despite turning off the midi ports (midiin2 (spark controller) in Ableton Preferences.

Therefore unable to load up Ableton template and not even able to manually map!

A clearer guide for Ableton set up would be good

Using Win7, spark version 1.1.1

Kevin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1.539
  • Karma: 81
    • http://www.arturia.com
Re: warning:MIDI ports
« Reply #5 on: June 01, 2011, 09:35:59 am »
Hi moogy,
you can have more details about Ableton Live template here.
To connect Spark Controller with Spark software you need to disable both Spark In and Out in Live preferences.

Hope this helps
Best
Kevin
Kevin
Soft Arturia

moogy blues

  • Jr. Member
  • **
  • Posts: 53
  • Karma: 1
    • Acoustic Focus
Re: warning:MIDI ports
« Reply #6 on: June 01, 2011, 09:48:37 am »
Hi

I've just turned my computer on this morning. Got a new message saying your controller is not upto date but more importantly the spark now operates the software.

Yesterday I just closed ableton and reloaded the software without a complete PC restart. The MIDI connections in this case only established when the PC was shutdown and restarted.

I will now spend the rest of the day figuring this thing out  :)

« Last Edit: June 02, 2011, 07:53:52 pm by moogy blues »

 

Carbonate design by Bloc
SMF 2.0.2 | SMF © 2011, Simple Machines