July 25, 2014, 01:26:15 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: Spark - excessively loud in Logic  (Read 2316 times)

vestan_pance

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Spark - excessively loud in Logic
« on: May 29, 2011, 07:24:45 am »
Hi,

Just bought Spark yesterday and initially ran it in stand-alone mode, which was absolutely fine.

Subsequently loaded it up as a software instrument channel in Logic, and two things happened.

a) I got the message about disabling Private In/Out which I'm still trying to figure out how to do.
b) The pattern is way louder than it was when recorded stand-alone - some of the samples which trigger are massively distorted - to the point where it's unusable - this was based on the industrial kit.

I was thinking that maybe the two things could be related - possibly multiple midi messages are firing at the same time and causing things to trigger twice?  But as I can't figure out how to disable the ports in Logic I can't test that theory.

Any help would be appreciated.

vestan_pance

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Spark - excessively loud in Logic
« Reply #1 on: May 31, 2011, 06:44:21 am »
Although I still haven't figured out how to disable the private in/out ports in Logic, I no longer think that this is the issue.

It could possibly be down to the fact that the initial project was done using the 1.0 version of the software/firmware and was subsequently reloaded into Spark following the upgrade to 1.1.1 / 1.1.0.

Kevin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1.537
  • Karma: 81
    • http://www.arturia.com
Re: Spark - excessively loud in Logic
« Reply #2 on: May 31, 2011, 09:23:58 am »
Hi,
About the Private MIDI ports.
Spark use these ports to communicate with the controller. We have no way to know if they are opened by the host.

On Mac OSX, the MIDI driver is multi client so the ports will be opened by both the host and the plugin.
The most problematic is the Private In because if it is opened by the host, the host will forward the MIDI messages to the plugin and they will be interpreted as standard MIDI messages, not Spark Private messages. This causes unexpected behavior of the plugin.

On Windows, the MIDI driver is not multi client so if the host already opened these ports, Spark software will not be able to connect to the Controller.

To diable MIDI port on Logic:
- Open the environment window
- Go to the Click&Ports layer
- Then New -> Instrument
  call it "Null" or something and make sure it's set to no output port in that object's inspector parameters.
- Cable "Spark Private In" to this "Null" instrument. Now, all MIDI data coming into Logic on that port will be effectively nuked, and will not reach the rest of Logic and interfere with other things.

Of course, you'll need to save this setup as a template or song in order to use it in the future.


About the loudness of the project created with the 1.0. Does it sounds same on Standalone and Audio Unit with 1.1.1?

Best
Kevin
Kevin
Soft Arturia

minehead

  • Apprentice
  • *
  • Posts: 22
  • Karma: -8
Re: Spark - excessively loud in Logic
« Reply #3 on: May 31, 2011, 09:45:46 pm »
Hi,

Just bought Spark yesterday and initially ran it in stand-alone mode, which was absolutely fine.

Subsequently loaded it up as a software instrument channel in Logic, and two things happened.

a) I got the message about disabling Private In/Out which I'm still trying to figure out how to do.
b) The pattern is way louder than it was when recorded stand-alone - some of the samples which trigger are massively distorted - to the point where it's unusable - this was based on the industrial kit.

I was thinking that maybe the two things could be related - possibly multiple midi messages are firing at the same time and causing things to trigger twice?  But as I can't figure out how to disable the ports in Logic I can't test that theory.

Any help would be appreciated.
I find it unbelievable that Arturia doesn't know their own product, you have to knock the faders down to the floor on some of these outputs, most of them...and the samples themselves vary WILDLY in amplitude, so you spend more time with setting levels with the mixer and with individual settings than you do in beat creation...if you load some of the kits, one is that Brazilian I think, you just hear this painfully loud splash cymbal just firing over & over, just a ridiculous pattern that is horrible to listen to !!!! I don't use their patterns, but of course I'm going to check them out...what the heck is up with that insanely childish pattern ?! this product has me scratching my head...i like things about and I hate things about it...those samples should have been normalized to some standard, it's like there was no QC or competent testing of this product before it hit the shelf. A room full of chimps could have had better luck...

vestan_pance

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Spark - excessively loud in Logic
« Reply #4 on: May 31, 2011, 11:23:28 pm »
Kevin,

Many thanks for your response.

I have done as you advised (I created a new monitor and wired the Private In to that in the environment) - it still displayed some wierd effects, although I've since used a different kit and that seemed fine.

I did notice some other wierd behaviour when used as a plugin - I know that the Filter etc are not automatable within a host, but I found that if I pressed the x/y pad whilst the Spark was playing it would trigger sample hits instead of acting as an x/y pad.  Maybe I should raise that as a separate post.

With regard to whether the issue appears on the stand-alone plugin - I will test and post back the results.

Regards,

Steve

vestan_pance

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Spark - excessively loud in Logic
« Reply #5 on: June 01, 2011, 12:59:22 am »
I can confirm that loading the standalone version of Spark and running the project created originally in 1.0 against the 1.1.1 version of the software I do NOT experience the same distortion as I did when I ran it as a plugin (within Logic).

It sounds exactly the same as the original.

Steve.

abertronix

  • Newbie
  • *
  • Posts: 2
  • Karma: 1
Re: Spark - excessively loud in Logic
« Reply #6 on: June 01, 2011, 04:44:00 am »
Thank-you Kevin for the explanation about disabling the midi port in Logic. I thought it would be somewhere in the environment window but wasn't sure about how to go about doing it. 
I just wanted to say I love the arturia spark . I think its a great product. A great range of kits and instruments, all top class.
A word to Minehead- All you have done is bagged the product. The moderators have been polite and helpful and you have been extremely rude. You must be aware that when you buy into a product especially one that has just come out that you cant expect everything to be perfect. Be patient and give it some time and Im sure any bugs will be eventually sorted out.

Kevin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1.537
  • Karma: 81
    • http://www.arturia.com
Re: Spark - excessively loud in Logic
« Reply #7 on: June 01, 2011, 09:21:22 am »
Steve,
The X/Y pad issue is exactly related to the Private MIDI port. If you disable them by following the instruction above it will disappear.
About the distortion, does it happens only with this project?
Dos it happens every time you load it?

@albertronix: thank you for the feedback
@MineHead: the levels has been set correctly on each project. If you encounter some problem with it, can you create a dedicated topic and we will try to find what is wrong.

Best
Kevin
Kevin
Soft Arturia

CC4

  • Beta-testers
  • Full Member
  • *
  • Posts: 148
  • Karma: 13
    • http://home.cogeco.ca/~cc4/
Re: Spark - excessively loud in Logic
« Reply #8 on: June 01, 2011, 11:57:17 pm »
you have to knock the faders down to the floor on some of these outputs, most of them...

it's loud in other sequencers too...  don't forget your master volume knob.  one of my requests in Beta testing was to either completely disable or offer an option to disable the memory setting for the master volume knob.

vestan_pance

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Spark - excessively loud in Logic
« Reply #9 on: June 02, 2011, 08:19:00 pm »
Ok I tested this again.

Stand-alone mode (1.1.1)

Selected the Industrial Kit.
Erase all patterns.
Select pattern A1.
Record a pattern.
Save as Industrial 3.
Quit Spark Standalone.

Load Logic 9 (9.1.4)

Create a new Software Instrument track and assign Spark.
Open the Industrial 3 project.
Wire up the environment as per instructions above.
Start playback.

The samples are still massively distorted and far louder than they are on the stand-alone version, to the point where it is unusable.  Pads 4 and 5 are shockingly bad.

I haven't fully tested with other kits, but this is a real issue for me with Spark.

Steve.

rcmusic

  • Beta-testers
  • Sr. Member
  • *
  • Posts: 258
  • Karma: 10
Re: Spark - excessively loud in Logic
« Reply #10 on: June 02, 2011, 10:23:26 pm »
Is this happening instrument/ pad that have effects on? ( check on the mixer page)

vestan_pance

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Spark - excessively loud in Logic
« Reply #11 on: June 03, 2011, 08:45:34 pm »
I can go into the mixer page and push all the levels down to zero when it's operating as a plugin and it still doesn't make any difference to the overall sound.  Some of the channels have effects on, some don't.  It doesn't seem to make any difference.

Steve.

vestan_pance

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Spark - excessively loud in Logic
« Reply #12 on: June 04, 2011, 04:53:11 pm »
Just discovered that this only seems to happen when the plugin is loaded as a multiple output version - when loaded as a stereo out plugin it seems to be fine.

vestan_pance

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Spark - excessively loud in Logic
« Reply #13 on: June 04, 2011, 05:01:16 pm »
Right - so I've found the problem, and maybe it's me being a dumbass I don't know.  So based on my last post, the problem only seems to happen when loaded as a multiple out plugin, and not the stereo version.

So that gets me thinking - and wondering if the signal is somehow being doubled up - and sure enough it is.  The main track which hosts the plugin has the output being sent to Stereo out (which is the combined output for Spark as far as I can tell) - but also when expanded, the individual outputs also route to Stereo out - thus doubling the signal.  If I reduce the master fader on the master track, then the problem goes away and everything sounds good again.

Kevin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1.537
  • Karma: 81
    • http://www.arturia.com
Re: Spark - excessively loud in Logic
« Reply #14 on: June 06, 2011, 09:55:44 am »
Hi vestan,
You are right, when you are in multi out mode, the instrument are played both in the plugin master out and in each separate output.
The multi out mode will be enhanced in the forthcoming update to solve this.

Best
Kevin
Kevin
Soft Arturia

 

Carbonate design by Bloc
SMF 2.0.2 | SMF © 2011, Simple Machines