September 19, 2014, 07:53:22 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: Keylab49 Won't Turn On at All!!!  (Read 78 times)

then000bster

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Keylab49 Won't Turn On at All!!!
« on: August 26, 2014, 08:41:21 pm »
I wanted to try using a different power source other than usb and found a Dc input lying around and plugged it in. The input screen lit up for a few seconds, a few of the buttons flickered as well as one of the pads before going blank. I then tried to turn it on again, but it wouldn't work. I then tried plugging it in normally through my computer like I always do and it still doesn't show any signs of power. I then looked at the Dc input and realized it was a 12v instead of 5, and 1A instead of .5A. I am afraid that I short circuited my Keylab and that it is done for good. Is there anything I can do?

Amalgamoth

  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: Keylab49 Won't Turn On at All!!!
« Reply #1 on: August 31, 2014, 10:57:44 pm »
Hey,
Well I'm not really an expert, but have you also tried afterwards to power the dc input with the correct adaptor & specs? And have you also checked whether powering by usb is possible? Even if the latter wouldn't be your method of choice you could still try it out just to see if there's still "somebody home in there".

petelachatte

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Keylab49 Won't Turn On at All!!!
« Reply #2 on: September 05, 2014, 11:39:42 am »
Well ... you killed it. Sorry, no other option.

 

Carbonate design by Bloc
SMF 2.0.2 | SMF © 2011, Simple Machines