April 24, 2014, 02:04:34 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: Disable Spark Privat In = Canīt record MIDI  (Read 941 times)

storoi90

  • Apprentice
  • *
  • Posts: 23
  • Karma: 0
Disable Spark Privat In = Canīt record MIDI
« on: November 05, 2012, 01:54:34 pm »
Why should i disable Spark Private In exactly, like you say in the knowledge base?

When i disable Spark Private In, i canīt record MIDI with the spark controller in Pro Tools. It only letīs me record with my M-Audio Oxygen 49.

When i engage Spark Private In, i can record MIDI with the Spark controller, but it wonīt play it back!
It will play it back if i record with the Oxygen 49 however. This is so strange.

Whatīs going on here? Please respond!
« Last Edit: November 05, 2012, 02:09:18 pm by storoi90 »

Kevin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1.412
  • Karma: 78
    • http://www.arturia.com
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #1 on: November 06, 2012, 09:40:25 am »
Spark Private In is a private communication port between Spark Controller and Spark software.
If you want to record MIDI from Spark, you have to record it from Spark plugin.
Kevin
Soft Arturia

terrym

  • Beta-testers
  • Sr. Member
  • *
  • Posts: 295
  • Karma: 40
    • soundcloud.com/logicaldream
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #2 on: November 06, 2012, 09:22:01 pm »
hi storoi
i think i had this problem if you look at the midi recorded its on different keys  i think it was an octave out if you want to record the beats with the controller when your done transpose up an octave and they should play in spark not sure what i did ill have a look into it again as im using cubase now.

storoi90

  • Apprentice
  • *
  • Posts: 23
  • Karma: 0
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #3 on: November 11, 2012, 02:23:16 am »
aha! Thanx terrym, i'll try moving up the notes to see if that helps ;)

storoi90

  • Apprentice
  • *
  • Posts: 23
  • Karma: 0
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #4 on: November 13, 2012, 02:45:27 pm »
Quote
Spark Private In is a private communication port between Spark Controller and Spark software.
If you want to record MIDI from Spark, you have to record it from Spark plugin.

So should i disable the private in port? Because when i do, i canīt record MIDI.

When i then record MIDI with the Spark controller, itīs actually 5 octaves off in the MIDI Editor in Pro Tools 8.0.5.
So i have to move all of the notes up 5 octaves after i record with Spark.

Just pointing this out to you guys at Arturia.

Kevin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1.412
  • Karma: 78
    • http://www.arturia.com
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #5 on: November 13, 2012, 02:54:56 pm »
Quote
Spark Private In is a private communication port between Spark Controller and Spark software.
If you want to record MIDI from Spark, you have to record it from Spark plugin.

So should i disable the private in port? Because when i do, i canīt record MIDI.

Yes you have to disable it.

You should not record MIDI directly from Spark controller, you should record it from Spark plugin.

Create a MIDI track and choose Spark plugin (not the controller) as MIDI input. In Spark Preferences, enable "Send MIDI from Pads" and/or "Send MIDI from Sequencer".

Kevin
Soft Arturia

terrym

  • Beta-testers
  • Sr. Member
  • *
  • Posts: 295
  • Karma: 40
    • soundcloud.com/logicaldream
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #6 on: November 13, 2012, 03:23:31 pm »
Hi storo . one  other way is to set all pads to the lower (-5oct) key ie cmd click on the pad and midi learn on -2oct  (12) bass drum.and change all the pad to the next  key i tried this on cubase 6.5 and it works.
otherwise im not sure how it works with protools but if you can load a vst and then a midi channel/track and see if you have spark in and spark out to select.

regards
terym

storoi90

  • Apprentice
  • *
  • Posts: 23
  • Karma: 0
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #7 on: November 16, 2012, 02:10:23 am »
Quote
You should not record MIDI directly from Spark controller, you should record it from Spark plugin.

Create a MIDI track and choose Spark plugin (not the controller) as MIDI input. In Spark Preferences, enable "Send MIDI from Pads" and/or "Send MIDI from Sequencer".

I might have to try terrymīs suggestion on this, cuz i tried your thing Kevin but it just wonīt work.

I enabled both "Send Midi from Pads" and (or) "Send MIDI from Sequencer", the problem is that you say i should record from the Spark plugin, and choose that as my input.
The only options i have to choose from as my MIDI-inputs are:

"Oxygen 49" (My keyboard), and "Spark Controller, Spark Public IN".

I donīt have "Spark plugin" to choose as my MIDI-input.

The MIDI-output is set to "VST Spark 1 - Channel 1".




Kevin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1.412
  • Karma: 78
    • http://www.arturia.com
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #8 on: November 16, 2012, 09:30:15 am »
I have to find a Pro Tools 8 install because I only have Pro Tools 10 on my computer.
I will get back to you as soon as I have tested it.
Kevin
Soft Arturia

storoi90

  • Apprentice
  • *
  • Posts: 23
  • Karma: 0
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #9 on: November 16, 2012, 01:29:56 pm »
Thanks Kevin.


Kevin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1.412
  • Karma: 78
    • http://www.arturia.com
Re: Disable Spark Privat In = Canīt record MIDI
« Reply #10 on: November 19, 2012, 09:33:16 am »
Did not find any computer with PT 8 in the office. I might have to reinstall a setup :(.
Just an idea, are you running the latest version of Spark.
The MIDI out has been added for RTAS in the 1.5.
You can check it in the about view (click on the Spark logo).
Kevin
Soft Arturia

 

Carbonate design by Bloc
SMF 2.0.2 | SMF © 2011, Simple Machines