Compatibility with macOS Catalina

catalina-icon

Dear Customers.

Our virtual instruments and effects are now compatible with macOS 10.15 Catalina.

Before upgrading, please make sure your DAW, third party plug-ins and your hardware devices drivers are compatible with it as well.

Also keep in mind that 32-bits applications and plug-ins are not longer supported by MacOS Catalina.

Best regards

The Arturia team


If you have any further questions, feel free to contact us.